Manjaro Update 2015-03-13 (stable)

We are happy to announce our fourth update for Manjaro 0.8.12.

This time we are shipping the latest beta driver from AMD: Catalyst 15.200. Why? It is simple. It supports Xorg-Server 1.17-series. So we updated to the latest xorg-server 1.17.1 package and all additional video drivers.

XFCE 4.12 desktop got updated to final release with our additional patches. KDE Apps is now at 14.12.3, KDE to 4.14.6 and Plasma to 5.2.1. New point-releases for some of our kernel-series we included in this update cycle.

Most of our work went into our tools. manjaro-tools 0.9.7 is ready now! It ships now with branding support and is now more flexible than before.

Pamac 2.2 got tuned under the hood. User won’t see any changes at first sight. However we need still your support for translating our tools.

Game-wise we updated steam to get even more support on our OS. Last but not least we can welcome David Linares (mcder3) to our artwork team. Check out his new Maia theme he is doing for our Plasma 5 edition of Manjaro Linux!

Some updates to mention: firefox 36.0.1, xfce 4.12.0, linux310 3.10.71, linux314 3.14.35, linux316, linux318 3.18.9, linux319 3.19.1, virtualbox 4.3.24, calligra 2.9.0, plasma5-themes-maia 0.2.0, catalyst 15.200, libreoffice-fresh 4.4.1, steam-manjaro, kde-apps 14.12.3, kde 4.14.6, plasma 5.2.1

This includes also regular Archlinux upstream fixes (Mar 13 17:46:31 CET 2015) Please give us feedback and report any findings with this update.

Kind regards, Manjaro Development Team

Current supported kernels

  • Linux310 3.10.71
  • Linux312 3.12.38
  • Linux313
  • Linux314 3.14.35
  • Linux316
  • Linux318 3.18.9
  • Linux319 3.19.1

Package changes

  • community i686: 557 new and 537 removed package(s)
  • community x86_64: 556 new and 533 removed package(s)
  • core i686: 43 new and 41 removed package(s)
  • core x86_64: 43 new and 41 removed package(s)
  • extra i686: 960 new and 988 removed package(s)
  • extra x86_64: 960 new and 987 removed package(s)
  • multilib x86_64: 20 new and 21 removed package(s)


Before updating, check if you have followed lines in your /etc/pacman.conf file:

# If upgrades are available for these packages they will be asked for first
SyncFirst    = manjaro-system

Written on March 13, 2015